phpcms前台注入导致任意文件读取漏洞【/phpcms/modules/content/down.php】
首页 >  Phpcms  > 2016年10月04日阅(2898)评(0

漏洞名称:phpcms前台注入导致任意文件读取漏洞

补丁文件:/phpcms/modules/content/down.php

漏洞描述:phpcms的/phpcms/modules/content/down.php文件中,对输入参数$_GET['a_k']未进行严格过滤,导致SQL注入的发生,黑客可利用该漏洞读取任意文件。【注意:该补丁为云盾自研代码修复方案,云盾会根据您当前代码是否符合云盾自研的修复模式进行检测,如果您自行采取了底层/框架统一修复、或者使用了其他的修复方案,可能会导致您虽然已经修复了改漏洞,云盾依然报告存在漏洞,遇到该情况可选择忽略该漏洞提示】

我的版本是phpcms_v9.5.10_UTF8

搜索代码:parse_str($a_k);(查找全部)不出意外的话有两处

第一处:约17行

在其前面加上:$a_k = safe_replace($a_k);

第二处:约97行

在其前面加上:$a_k = safe_replace($a_k);

第三处:搜索代码:file_down($fileurl, $filename);(约128行)

在其前面加上:$fileurl = str_replace(array('<','>'), '',$fileurl);

phpcms注入漏洞【/api/phpsso.php】
phpcms v9宽字节注入【phpcms/modules/pay/respond.php】

有朋自远方来...评论一下呗O(∩_∩)O哈哈~

QQ
昵称*
邮箱*
主页